Ask Your Question
0

NVIDIA driver underclocks on battery

asked 2011-11-18 15:12:18 -0600

Speels gravatar image

updated 2011-11-18 15:13:18 -0600

I have the latest NVIDIA proprietary drivers from RPM Fusion installed on Fedora 16. It uses "PowerMizer" to underclock the GPU in an attempt to conserve power when I am on battery. It makes the x server crash whenever I am running a VM, 3D accelerated game, or any flash object. Is there any way that I can disable this feature? Could I trick it into thinking that I am on AC power? I turned off polling, but to no avail.

Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-18 15:50:42 -0600

SoumyaC gravatar image

updated 2011-11-18 16:06:25 -0600

You can consider disabling PowerMizer. Check the below link

1) PowerMizer

2) If the above doesn't work then look for this link

While following the 2nd link please set the Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1" in "Device" section of Xorg.conf.

3) If the above two fails to work, kindly create a file /etc/modprobe.d/nvidia.conf and write the following

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

I expect any one of the three should help you !

edit flag offensive delete link more

Comments

Add the options part given I mentioned above in that Device Section. Also try with "PowerMizerEnable=0x0" to disable PowerMizer

SoumyaC gravatar imageSoumyaC ( 2011-11-19 01:03:30 -0600 )edit

Very Strange, it shouldn't have happened. Can you post the output for the following command -

nvidia-settings -q GPUPerfModes -t

SoumyaC gravatar imageSoumyaC ( 2011-11-19 14:36:07 -0600 )edit

nvidia-settings -q GPUCurrentPerfLevel -t and nvidia-settings -q GPUCurrentClockFreqs -t outputs please

SoumyaC gravatar imageSoumyaC ( 2011-11-19 23:45:02 -0600 )edit

you mean in battery it gets crashed ? PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1 set this two options and remove your PowerMizerLevel option and check

one thing you can do is from this link http://tutanhamon.com.ua/technovodstvo/NVIDIA-UNIX-driver/ try playing around with the parameters

SoumyaC gravatar imageSoumyaC ( 2011-11-20 00:33:24 -0600 )edit

If you try and change the different parameters given from the above link and do a stress test in every case, you will have an idea which of them gets your GPU working perfectly according to your need

SoumyaC gravatar imageSoumyaC ( 2011-11-20 00:34:35 -0600 )edit

Question Tools

Stats

Asked: 2011-11-18 15:12:18 -0600

Seen: 847 times

Last updated: Nov 18 '11