Ask Your Question
8

How do I ban apps from using Gnome 3 (Adwaita) Dark Theme?

asked 2012-01-05 08:32:46 -0600

kparal gravatar image

updated 2014-09-29 04:54:07 -0600

mether gravatar image

Most of Gnome 3 applications in the default look (Adwaita) use bright theme. But some of them use dark theme (most notably totem and eog). I hate it, it makes me totally disoriented.

Is there an easy way to ban the Dark Theme globally? I.e. forbid all applications to opt-in for the dark theme and force them to use the default (bright) theme instead?

Thanks.

edit retag flag offensive close merge delete

Comments

I'm sure it can be done by editing the CSS that gnome3 uses. I haven't played around with it yet, so I can't exactly pin point what to change yet.

FranciscoD_ gravatar imageFranciscoD_ ( 2012-01-05 23:37:31 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-02-01 04:21:55 -0600

kparal gravatar image

Based on bigben87's solution I have a slightly better one. It is still highly suboptimal, but it seems nothing better exists at the moment. Please be aware that by copying part of the theme to you local directory you will no longer receive system updates of that theme (OTOH theme updates won't break it). It's advisable to re-do this approach once in a while (after distro upgrade and such).

  1. mkdir -p ~/.themes/Adwaita-NoDark
  2. cp -r /usr/share/themes/Adwaita/gtk-* ~/.themes/Adwaita-NoDark
  3. rm ~/.themes/Adwaita-NoDark/gtk-3.0/gtk-dark.css
  4. ln -s gtk.css ~/.themes/Adwaita-NoDark/gtk-3.0/gtk-dark.css
  5. Run gnome-tweak-tool and select Theme -> GTK+ Theme -> Adwaita-NoDark
  6. Run eog and totem and check that they are using light theme

Gnome-shell restart shouldn't be necessary. If you don't see the new theme in gnome-tweak-tool, restart Gnome Shell (Alt+F2 -> r -> Enter) and run the tool again.

How to put everything back:

  1. Run gnome-tweak-tool and select Theme -> GTK+ Theme -> Adwaita
  2. If you want you can also delete your modified theme:

    rm -r ~/.themes/Adwaita-NoDark

edit flag offensive delete link more

Comments

Step 4 should be: ln -s ~/.themes/Adwaita-NoDark/gtk-3.0/gtk.css ~/.themes/Adwaita-NoDark/gtk-3.0/gtk-dark.css. It works fine in Fedora 20. Thanks @kparal!

skytux gravatar imageskytux ( 2013-12-20 18:08:53 -0600 )edit

Thanx for this. I really hate the dark theme, and this solved my problem nicely.

andriesfc gravatar imageandriesfc ( 2014-05-10 09:02:58 -0600 )edit
1

answered 2012-01-31 17:16:54 -0600

bigben87 gravatar image

updated 2012-02-01 06:03:58 -0600

I found a simple, but brutal solution:

sudo mv /usr/share/themes/Adwaita/gtk-3.0/gtk-dark.css /usr/share/themes/Adwaita/gtk-3.0/gtk-dark.css_bck
sudo ln -s /usr/share/themes/Adwaita/gtk-3.0/gtk.css /usr/share/themes/Adwaita/gtk-3.0/gtk-dark.css

Afterwards EOG and Totem look a bit damaged restart the gnome-shell to fix this press Alt+F2 and run 'r'.

Undo procedure:

sudo unlink /usr/share/themes/Adwaita/gtk-3.0/gtk-dark.css
sudo mv /usr/share/themes/Adwaita/gtk-3.0/gtk-dark.css_bck /usr/share/themes/Adwaita/gtk-3.0/gtk-dark.css

If you did not make a backup or want to be sure to be back to default:

sudo yum reinstall adwaita-gtk3-theme

Afterwards EOG and Totem look a bit damaged restart the gnome-shell to fix this press Alt+F2 and run 'r'.

It would be nicer to achieve this by overriding a default in ~/.local or ~/.config or so, but I could not get it working that way.

edit flag offensive delete link more
-4

answered 2012-01-08 05:33:38 -0600

FranciscoD_ gravatar image

I've seen options in the gnome-tweak-tool that let you change the theme. Have you tried it yet?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-01-05 08:32:46 -0600

Seen: 14,844 times

Last updated: Feb 01 '12