Ask Your Question
1

Savely remove nvidia card

asked 2017-03-12 13:14:54 -0500

daniel88 gravatar image

updated 2017-03-13 13:36:10 -0500

Hi everyone,

I'm on Fedora 25, my desktop system has a Skylake CPU with integrated gfx and an Nvidia graphics card installed. I'm currently using the Nvidia card and everything works fine.

Now I want to remove the Nvidia card and use the CPU graphics as I now longer need the greater graphics performance. If I just do so and use the intel graphics my system now longer boots, it stops with the message:

 snd_hda_intel 0000:00:03.0: HSW/BDW HD-audio HDMI/DP requires binding with gfx driver

From what I understand (not much), there seems to be conflict of some kind between the intel and Nvidia driver. I googled around and tried to blacklist the kernel module "snd_hda_intel" in modprode.d, but this just results in a kernel panic after rebooting.

So, how can I safely switch from Nvidia to Intel without, if at all possible, a complete reinstallation? Thanks for all your help in advance!

Edit/Clarification: There is nothing in the bios to configure for this matter. The monitor is auto-detected and works just fine if I boot with just the CPU. I know that the module "snd_hda_intel" is responsible for sound, but I'm not convinced it has nothing to do with the nvidia card (which can output sound via hdmi etc.). So If I remove nouveau, everything should work?

edit retag flag offensive close merge delete

Comments

1

Did you reset the bios to use the integrated video? Did you remove the nvidia driver before taking the card out? Do not block sndhdaintel, as that is the sound driver and has nothing to do with video. Your internal video driver is not being installed. if you need to, put the nvidia back in, and make sure that the bios and driver load for the intel, before you remove the card.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-03-12 15:18:43 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-03-13 16:37:22 -0500

sideburns gravatar image

Once you can boot, use Ctrl-Alt-F3 to get to a text terminal. Log in, and run these commands as root:

dnf remove -y \*nvidia\*
reboot now

The first command will remove all of the proprietary nVidia drivers and the second, of course, will reboot. Or, if you haven't removed the card yet, use shutdown instead, so that you can safely remove the card from the box.

edit flag offensive delete link more
-1

answered 2017-03-14 06:26:38 -0500

madchem gravatar image

Try to boot your computer. As you will see GRUB2 menu - hit 'e' button and find word 'linux16'. You should add symbol '3' to this line, like this:

linux16 vmlinuz=... initrd=... 3

then hit ctrl+x and wait for login screen. You should boot into non-graphics mode. Login with your account name and password. Delete Nvidia proprietary driver with:

sudo dnf remove \*nvidia\*

and reboot.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-03-12 13:08:16 -0500

Seen: 249 times

Last updated: Mar 14 '17