Ask Your Question
0

Dependency broken for KDE : libgpgme-pthread.so.11 missing

asked 2017-03-06 17:09:39 -0600

Hi !

During the last update made by dnf. I end up with a broken dependency :

sudo dnf update --best --allowerasing                                          
Fedora 24 - x86_64 - Updates                             2.0 MB/s |  21 MB     00:10     
Fedora 24 - x86_64                                            2.0 MB/s |  47 MB     00:23     
Vérification de l'expiration des métadonnées effectuée il y a 0:00:32 sur Mon Mar  6 23:51:09 2017.                                                                                         
Erreur : package knode-libs-4.14.10-24.fc24.x86_64 requires libgpgme-pthread.so.11()(64bit), but none of the providers can be installed

When I check the content of the package. I see that dnf is not lying :

rpm -qR knode-libs-4.14.10-24.fc24

/sbin/ldconfig                                                                                
/sbin/ldconfig                                                                                
knode = 4.14.10-24.fc24                                                                       
libQt3Support.so.4()(64bit)
libQtCore.so.4()(64bit)
...
libgpg-error.so.0()(64bit)
libgpgme++-pthread.so.2()(64bit)
libgpgme-pthread.so.11()(64bit)
libgrantlee_core.so.0()(64bit)
...

Finally KDE-desktop doesn't work anymore. I try deinstalling the whole KDE and reinstall.But it doesn't work. Any advice ?

edit retag flag offensive close merge delete

Comments

I have the same problem: last update broke dependencies, and KDE will not load (the black screen with cursor and nothing happens). There is a possibility to switch to console (CTRL-ALT-F2).

Gene gravatar imageGene ( 2017-03-06 23:55:29 -0600 )edit

While some packages were quickly updated and the desktop was fixed, the issue remains.
Kmail, for one, will not start.

malkien gravatar imagemalkien ( 2017-03-10 03:46:49 -0600 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2017-03-10 09:59:51 -0600

updated 2017-03-10 10:00:31 -0600

Should be fixed by one or both of the following updates:

https://bodhi.fedoraproject.org/updat...

https://bodhi.fedoraproject.org/updat...

See also mailling list thread on the topic, https://lists.fedoraproject.org/archi...

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2017-03-06 17:09:39 -0600

Seen: 236 times

Last updated: Mar 10 '17