Ask Your Question
0

How to get vnc working on Fedora 25

asked 2017-03-05 00:31:28 -0500

owlbrudder gravatar image

I have two Fed 25 / Gnome 3 boxes that I want to connect via vnc.

I have ensured the respective firewalls allow vncserver to access ports 5900-5903 on both boxes.

I have set up screen sharing through the control panel applet and it says others can now access the machine via address vnc://[boxname].local

I try to access one box from the other using Remote Desktop Viewer, but all that happens is a delay of a fraction of a second and then the display of "Connection closed. Connection to host [address] was closed."

Clearly I have something set up incorrectly, but I don't know where to start looking and any advice would be appreciated.

Kind regards, Doug

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-03-05 04:06:38 -0500

Aeyoun gravatar image

You have to launch GNOME from a X session instead of Wayland. Click the gear icon on the login screen to change the session. VNC isn’t working on Wayland yet.

edit flag offensive delete link more

Comments

Thanks Aeyoun. Unfortunately that did not make any difference.

I have followed advice given on various fora but I still cannot get vncserver@:0.service to start without errors. Still tinkering, but I suspect I am doing something silly because it shouldn't be this hard. "8-[

owlbrudder gravatar imageowlbrudder ( 2017-03-05 22:31:31 -0500 )edit
0

answered 2017-04-25 17:45:11 -0500

I found a workaround here in the forum that works for me. Not ideal, but VNC (tigervnc server) works in Fedora25.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-03-05 00:31:28 -0500

Seen: 851 times

Last updated: Mar 05 '17