Ask Your Question
0

airplane mode not deactivate

asked 2017-02-28 02:45:58 -0600

Simone gravatar image

Hi, i have install fedora workstation for my first time on fujitsu esprimo mobile, but the airplan mode not deactivate. I see on grey "use the hardware button for deactivate airplane mode" but i active the wireless button bt it doesn't work

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-02 09:54:25 -0600

amitosh gravatar image

First of all, please make sure you do not have any hardware switched flipped off that has shutdown bluetooth or WiFi. Laptops may contain switches for WiFi and BT and Airplane mode. You can find such switches at either the back or sides of your laptop. Consult the manual of your laptop by your manufacturer for more info.

Airplane mode in Fedora (GNOME) uses rfkill to shutdown radios. The command rfkill list all will output all available radios and their states.

$ rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

This is the output of my Laptop in normal mode. If you see Soft blocked: yes then, rfkill unblock all will turn on all radios (WiFi,BT etc.) connected to your laptop. rfkill ublock all should also reset the Airplane Mode in the status bar.

Hope this helps!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-02-28 02:45:58 -0600

Seen: 195 times

Last updated: Feb 28 '17