Ask Your Question
0

Still windows 10 bootloader after installing Fedora

asked 2017-02-27 17:03:17 -0600

Zoker gravatar image

Hi there,

Today I tried to install fedora next to windows 10. After following the usual instructions (shrink 40GB windows partition, install fedora to that empty partition via automatic mode) the windows 10 bootloader is still the main bootloader and does not show my fedora installation (only my live boot usb stick is shown).

So how can I set grub as the main bootloader?

Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-27 19:17:44 -0600

LatentCC gravatar image

Did you specify a location for GRUB to be installed while you were installing Fedora? I've never installed Fedora via automatic partitioning so I always select the partition to which GRUB will be installed.

During installation, when you're deciding where it should be installed, click on your drive and select "I will configure partitioning" and click "done". Create your partition that will store your "/" mount point and then make sure you set /dev/sda or /dev/sda1 (or wherever the Windows boot menu is) to be your "/boot/efi" mount point. Whatever you do, do not format whatever partition you select to be your /boot/efi. This will wipe out the Windows boot record and you may not be able to boot into Windows10.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-02-27 17:03:17 -0600

Seen: 108 times

Last updated: Feb 27 '17