Ask Your Question
1

Help with scp-ing a large file

asked 2017-02-27 13:10:46 -0500

ukalumni gravatar image

I recently switched from an iMac at work to a custom linux build (Asus z170-a MB) running Fedora 25. I can scp a 170MB file within my office network, but when I try to push it through the firewall to our production servers, scp stalls and fails within just a few seconds.

I can push the exact same file with my iMac with no problems. Every time.

I have set the mtu on my linux machine from 1492 to 1400 to 9000 to 900. Doesn't help.

I was using the on-board networking on the Asus Z170-a. This morning, I added a new Intel ethernet card in hopes that that would fix it, but it did not. Same problem.

Can someone please help with this? I don't know what else to try.

edit retag flag offensive close merge delete

Comments

and regular ssh to 'your production servers' does work? Are you using standard port 22? So, you think this is firewall problem? What OS is the server running? Fedora? CentOS. Does firewall-cmd --list-all provide you with some useful information? Here is another source of valueable information: https://www.digitalocean.com/communit...

florian gravatar imageflorian ( 2017-02-27 14:09:06 -0500 )edit

Thanks for your reply. I can ssh to all of my servers without any problems. I can also scp small files, like a few mb, without problems.

We are using port 22.

Some servers are runing Ubuntu 14.04 and others are running Redhat 5.2.

I'm going to broaden this a bit because I just remembered something else. I recently tried pushing some large files (60MB or so) from my desktop to box.com , and those also stall, but again, when I pushed them from my iMac, they went without any problems.

I will run the firewall-cmd on my desktop tomorrow when I get back to the office

ukalumni gravatar imageukalumni ( 2017-02-27 16:19:03 -0500 )edit

is there any solution to restart the firewall? https://copify.ir

Payam Khaninejad gravatar imagePayam Khaninejad ( 2017-06-18 04:39:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-02-27 18:49:49 -0500

fcomida gravatar image

See whether sudo sysctl -w net.ipv4.tcp_sack=0 fixes your issue. Some CISCO equipment in between can cause your problem. Google for it.

edit flag offensive delete link more

Comments

You, sir, are a genius. Or at least exceedingly helpful. Thanks so much. This has been making me crazy, but I just tested this on my laptop, connected to our VPN. It failed when I tried it a couple of hours ago, but it is now working after running that command.

ukalumni gravatar imageukalumni ( 2017-03-01 22:02:52 -0500 )edit

Question Tools

Stats

Asked: 2017-02-27 13:10:46 -0500

Seen: 249 times

Last updated: Feb 27 '17