Ask Your Question
3

Why does my Nvidia driver get messed up with the recent update?

asked 2017-02-26 15:21:57 -0600

bluepixels gravatar image

updated 2017-02-28 21:22:07 -0600

Hello,

After the latest Fedora update (which included updating to kernel: 4.9.11-200) my Nvidia drivers are all messed up. My 2560x1440 monitor only displays at 1024x768 4:3. I am running in Xorg, not Wayland.

I installed the proprietary driver via RPM Fusion, and have been running it without issue since Fedora 24. However, that is no longer the case.

After trying many different solutions and messing up my system, I did a clean install. But, the problem still occurs.

The RPM Fusion Guide I follow: https://rpmfusion.org/Howto/nVidia

I need the proprietary driver for photo editing with OpenCL, and video editing.

UPDATE - TO SOLVE THIS PROBLEM

  1. Run the selinux update
  2. Reboot
  3. Install the Nvidia driver *but wait 5 mins before you reboot so kmod can build
  4. Reboot (after 5 minutes)

Now I have to decide if I want to return the AMD RX 470 I bought onilne while dealing with this problem...

edit retag flag offensive close merge delete

Comments

If you installed the akmod packages check on the logs for any error. If you didn't, your kernel is too new and rpmfusion hasn't yet provided a package for your kernel version.

fcomida gravatar imagefcomida ( 2017-02-26 16:53:51 -0600 )edit

I also have just experienced similar problem and the cause is the SELinux update. open "SELinux Alert Browser" if you see a log related to "nvidia-installer" then that's it. I may be able to help if that's the case.

arya s. gravatar imagearya s. ( 2017-02-26 17:22:30 -0600 )edit

Thanks @fcomida, yes I installed akmod, but I am not sure how to check the log files.

bluepixels gravatar imagebluepixels ( 2017-02-26 17:51:13 -0600 )edit

@arya s. There aren't any SELinux Alerts related to nvidia-installer. But, I don't know how long the alerts stay there. I'll try to install the drivers again and check the SE Linux Alerts after.

bluepixels gravatar imagebluepixels ( 2017-02-26 17:54:45 -0600 )edit
1

Check your logs with dmesg and journalctl. You can temporarly disable selinux with setenforce 0

fcomida gravatar imagefcomida ( 2017-02-26 19:37:34 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-28 20:23:38 -0600

xmetax gravatar image

updated 2017-02-28 20:25:39 -0600

It sounds like an issue many other NVIDIA users are reporting. It is referenced here:

https://bugzilla.redhat.com/show_bug....

Don't disable SELinux :) The issue is being caused by the selinux-policy package. An update has been released. Simply run

sudo dnf update

It will automatically find the update: selinux-policy-3.13.1-225.11.fc25.noarch

Then reboot.

edit flag offensive delete link more

Comments

BTW, the issue appears to be present for binary, RPM Fusion, and Negativo17 installer users.

xmetax gravatar imagexmetax ( 2017-02-28 20:28:42 -0600 )edit

Thanks for all the help. I just updated to selinux-policy-3.13.1-225.11.fc25.noarch, unfortunately it still booted into the low resolution mode. I think @xmetax might be right that the problem is with the RPM Fusion binary. Maybe related to this bug and waiting 5 mins: https://bugzilla.rpmfusion.org/show_b...

bluepixels gravatar imagebluepixels ( 2017-02-28 20:54:39 -0600 )edit

The NVidia driver is finally working again! After updating to selinux-policy-3.13.1-225.11.fc25.noarch and installing the driver, I had to wait 5 mins for kmod to get built for the new kernel. Not waiting 5 minutes resulted in failure.

bluepixels gravatar imagebluepixels ( 2017-02-28 21:15:24 -0600 )edit

Awesome! Strange you have to wait 5 minutes for the kmod build. Haven't seen that issue but I'm using DKMS with the Negativo drivers.

xmetax gravatar imagexmetax ( 2017-02-28 22:16:27 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2017-02-26 15:20:48 -0600

Seen: 1,579 times

Last updated: Feb 28 '17