Ask Your Question
0

vsftpd can't visit /var and subdirectory

asked 2012-03-06 03:00:16 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

hello,

I'm using Fedora 16, and yum the vsftpd. At first any thing is OK but vsftpd can't start automatically when system boot. So I put links in wants.

su
cd /etc/systemd/system/multi-user.target.wants/
ln -s /lib/systemd/system/vsftpd.service
cd /etc/systemd/system/graphical.target.wants/
ln -s /lib/systemd/system/vsftpd.service

Then, reboot, vsftpd starts with system, but there isn't any vsftpd.service in /lib/systemed/system/*wants/, so I can not let it stop automatically start, even use

systemctl off vsftpd.service

What's more, I can't visit /var via ftp client.

Sorry, I'm not English speaker.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-03-06 14:17:09 -0600

mooninite gravatar image

updated 2012-03-06 14:17:51 -0600

Please read the Fedora documentation on how to use "systemd" - the replacement service manager: http://docs.fedoraproject.org/en-US/Fedora/16/html/SystemAdministratorsGuide/ch-ServicesandDaemons.html#s1-services-configuring

For example:

# systemctl enable vsftpd.service

This is the proper way to enable vsftpd on boot.

You may also find the documentation in your native language by switching the language with the drop-down box at the top left of the page.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-06 03:00:16 -0600

Seen: 306 times

Last updated: Mar 06 '12