Ask Your Question
1

External monitor fedora 25

asked 2017-02-21 06:53:27 -0500

matdemy gravatar image

I'm trying to set up my laptop to use an external monitor. This monitor is 2560x1440p. I am able to select it as on option the screen goes black but then it comes back again as a 1080p and not 1440p as I would have liked. I used to fix it (when I still ran ubuntu) by running some xrandr commands but those don't work any more. These were the commands that I used. If I don't run these commands the option for the 1440 resolution doesn't show up in the first place. I switched back to x11 to see if my old commands worked there. How do I fix this so it works in either Wayland or X11?

xrandr --newmode "2560x1440_33.00" 162.77 2560 2688 2960 3360 1440 1441 1444 1468 -HSync +Vsync
xrandr --addmode HDMI1 2560x1440_33.00

xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
xrandr --addmode HDMI1 2560x1440_60.00

They don't work anymore unfortunately. I'm not sure how to fix this but there is some useful information that I found that might help.

xorg log

[  4598.177] (II) intel(0): switch to mode 1920x1080@60.0 on HDMI1 using pipe 1, position (1920, 0), rotation normal, reflection none
[  4598.218] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[  4599.141] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4599.308] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4599.452] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4651.043] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4662.477] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4704.706] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4740.230] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4745.736] (II) intel(0): resizing framebuffer to 4480x1440
[  4745.785] (II) intel(0): switch to mode 2560x1440@16.9 on HDMI1 using pipe 1, position (1920, 0), rotation normal, reflection none
[  4745.894] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 360), rotation normal, reflection none
[  4746.028] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4746.308] (II) intel(0): resizing framebuffer to 3840x1080
[  4746.308] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[  4747.165] (II) intel(0): switch to mode 1920x1080@60.0 on HDMI1 using pipe 1, position (1920, 0), rotation normal, reflection none
[  4747.339] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4747.512] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4747.892] (--) intel(0): HDMI max TMDS frequency 225000KHz
[  4780.910] (II) intel(0): resizing framebuffer to 4480x1440
[  4780.948] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 360), rotation normal, reflection none
[  4780.970] (II) intel(0): switch to mode 2560x1440@16.9 on HDMI1 using pipe 1, position (1920, 0), rotation ...
(more)
edit retag flag offensive close merge delete

Comments

First, xrandr doesn't work in Wayland. What resolution is your internal laptop display? What connection are you using for the external monitor. It looks like your laptop is using an internal DisplayPort connection for the screen which seems odd and you're connecting the external monitor with HDMI. It looks like it tries to switch to the mode, but isn't successful. The refresh rate is 16.9Hz, so that could be why.

ssieb gravatar imagessieb ( 2017-02-23 14:24:21 -0500 )edit

Do ls /sys/class/drm. Assuming you're connecting to the HDMI port, there should be a link in there with HDMI in the name. Run edid-decode /sys/class/drm/<name from ls>/edid and paste the output here. If that command doesn't exist then do dnf install xorg-x11-utils.

ssieb gravatar imagessieb ( 2017-02-23 14:27:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-04-25 16:05:50 -0500

greatlinux gravatar image

Try using a thunderbolt port on laptop (if it is present), connecting the monitor to the that port will probably resolve the issue, no other change needed.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-02-21 06:53:27 -0500

Seen: 858 times

Last updated: Feb 21 '17