Ask Your Question

DOS bootable USB drive Created with UNetbootin - This is not a bootable disk.

asked 2017-02-20 22:42:44 -0600

wolfv gravatar image

updated 2017-02-27 18:31:37 -0600

I am trying to created a DOS bootable USB drive in for a BIOS update. I do not have a Windows operating system. The following instructions are performed entirely on a Fedora 25 machine. How can I make the USB flash drive DOS bootable?


I have done the following twice, with the same result each time.

Use GParted to partition USB drive and set boot flag.

Use UNetbootin to install DOS on partitioned USB drive.

Attempt to Boot the PC to DOS:

Power > Restart
F2 > BIOS, Boot order > Legacy > double click on USB

Black screen opens with white flashing cursor.  There is nothing else on the screen.
Typing on keyboard doesn't show up on screen or move the cursor.
alt+ctrl+del boots to Fedora.

Is that how DOS is supposed to work?

As sideburns said, fdisk -l asterisk just after the Device name indicates the boot flag is set. From Fedora terminal:

$ sudo fdisk -l
Disk /dev/sdb: 983 MiB, 1030750208 bytes, 2013184 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x696151a9

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1  *     2048 2013183 2011136  982M  6 FAT16

What else can I try?

Thank you.

Operating system: Fedora 25, Linux kernel 4.8, Gnome 3.22.2

PC Hardware: Haswell Intel NUC Kit D54250WYK, Intel Core i5-4250U CPU

USB flash drive: 1.0 GB Drive VBTM Store 'n' Go


With the same USB thumb drive, I used Rufus on my neighbor's Windows 7 to make USB DOS bootable, and that worked.

Also submitted bug to FreeDOS

edit retag flag offensive close merge delete


Where did you get the .iso from? I'd like to get a copy and see if it works for me.

sideburns gravatar imagesideburns ( 2017-02-24 02:47:51 -0600 )edit

@sideburns, from terminal:
$ sudo dnf install gparted
$ sudo dnf install unetbootin

wolfv gravatar imagewolfv ( 2017-02-24 10:36:06 -0600 )edit

I'm asking where you got the .iso of DOS from.

sideburns gravatar imagesideburns ( 2017-02-24 13:45:37 -0600 )edit

@sideburns, There's an .iso of DOS? I used UNetbootin to make USB drive DOS bootable:
Distribution: FreeDos
Type: USB Drive, Drive: /dev/sdb1
At what point was I supposed to use .iso?

wolfv gravatar imagewolfv ( 2017-02-24 15:47:57 -0600 )edit

I don't know of an .iso of DOS; that's why I asked. Simply copying the FreeDOS files to a flash drive and making it bootable probably won't work. Does what you downloaded come with installation instructions and if so, did you try them?

sideburns gravatar imagesideburns ( 2017-02-24 16:41:47 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2017-02-28 14:58:54 -0600

sixpack13 gravatar image

updated 2017-02-28 15:11:27 -0600

you should read what the Intel page tells:
BIOS Update [WY0044.BIO] - A .BIO file to be used for F7 BIOS Update

you even need no bootable usb stick and nor DOS on it !
  • fdisk your USB stick, create a (un-bootable) simple fat32 partition
  • mkfs.vfat /dev/sdx
  • download the file "WY0044.BIO" from Intel
  • md5sum it
  • copy it to your USB Stick
  • put usb stick into the NUC
  • power on and press F7 key
  • pray against devilish power cuts
  • and you are DONE with "BIOS update" !

(even 'cause you had paid your power bills orderly last times ...)


edit flag offensive delete link more


@sixpack13 That only works for Windows. For Linux, follow the "iflash BIOS Update" instructions. Apparently "regardless of operating system" is Intel's way of saying "the other methods only work with Windows".

wolfv gravatar imagewolfv ( 2017-02-28 18:09:53 -0600 )edit

I marked sixpack13's answer as correct, although I have not tried it myself, it's probably correct.

wolfv gravatar imagewolfv ( 2017-03-02 09:53:08 -0600 )edit

answered 2017-02-20 22:56:57 -0600

sideburns gravatar image

DOS and Windows require that a partition has the bootable flag set before you can use it to boot, and each physical drive can only have one bootable partition. (Linux ignores this.) Run this command in a terminal as root with the drive mounted:

fdisk -l

where the last character is a lower-case L, not a one. If there isn't an asterisk just after the Device name (in the column labeled Boot it's not set. If that's the case, use GParted to set the boot flag and try again.

edit flag offensive delete link more


I appended the "fdisk -l" output to the original question. But there is no column labeled "Boot".

wolfv gravatar imagewolfv ( 2017-02-20 23:22:59 -0600 )edit

Maybe it only shows if it's needed. I have an old Windows installation as well as Fedora, so it's going to show. And, it looks like your DOS drive uses lvm, and I doubt that DOS understands that. Maybe you should repartition the device without that and try again.

sideburns gravatar imagesideburns ( 2017-02-21 03:31:15 -0600 )edit

deleted nonsense

wolfv gravatar imagewolfv ( 2017-02-21 09:08:13 -0600 )edit

answered 2017-03-01 23:04:34 -0600

sixpack13 gravatar image

updated 2017-03-01 23:26:57 -0600

NO !
"F7 BIOS flash update instruction" is your friend

I've done this multiple.

My NUC D34010WYKH and yours D54250WYK playing in same bios-update area !

scroll down the linked page from my previous comment.

If you want to update your bios on a whatsoever-OS-driven NUC, do what I've written !
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-02-20 22:42:44 -0600

Seen: 3,075 times

Last updated: Mar 01 '17