Ask Your Question
5

Why Gnome3 notifications for system disks don't time out ?

asked 2011-11-29 05:35:42 -0600

ryran gravatar image

updated 2012-02-21 14:03:01 -0600

All right. So when you plug in an external disk of some kind, all the magic happens behind the scenes and then it gets automounted for you and you get a lovely [notify-send] notification that pops up giving you a chance to "Open with Files" or "Eject", right? If you don't click on the notification (either the two choices, or elsewhere in the notification) it doesn't go away--apparently it doesn't have a timeout (unless it's ridiculously long). That's fine by me. I like this behavior.

Now. I have a system disk with multiple partitions and various filesystems, all of which I don't need to be mounted all the time. Whenever I need to get at one of them, I open nautilus (Files) and click the appropriate FS in the tree on the left to mount it up. This works.

The problem however, is this: AFTER mounting it manually in this way, I get a never-times-out notification about said filesystem (Open with Files/Eject), which basically means I have an extra click I have to do.

Clearly the system just displays this notification whenever anything is mounted by the current user. I doubt there's any hope of fixing this annoyance, aside from doing things with root (can mount from the command-line to avoid the notification, but that's just silly), but I thought I'd ask anyway. Any hope?


EDIT: Finally bothered to create an account in Gnome's bugzilla, but before posting I spent a while searching for an existing report of this and FOUND IT: bugzilla.gnome.org/show_bug.cgi?id=665135

edit retag flag offensive close merge delete

Comments

Same here. When I plug one in too, the notification waits for me to click on it :/

FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-29 06:13:19 -0600 )edit

There is no particular settings for Gnome3 for setting the time out. I found a setting in org.gnome.settings-daemon.plugins.housekeeping (min-notify-period) in which you can set the time for the warnings to stay.

SoumyaC gravatar imageSoumyaC ( 2011-11-29 15:08:38 -0600 )edit
1

I'd suggest you file a bug. It makes no sense for notifications to stay for ten minutes. Specially when you have a permanent icon in the notification area for mounted drives. Please do post the bug id here once you've filed it. Thanks!

FranciscoD_ gravatar imageFranciscoD_ ( 2011-11-30 04:00:35 -0600 )edit

@ryran, I suggest you go with @FranciscoD_'s idea to file a bug and link it here in this question. I also felt 10 minutes time as sheer waste for a notification.

SoumyaC gravatar imageSoumyaC ( 2011-11-30 04:32:13 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-12-03 06:08:08 -0600

mether gravatar image

File a bug report in upstream GNOME bugzilla and then post here as followup.

edit flag offensive delete link more
0

answered 2012-01-07 02:17:19 -0600

fix automount notification in gnome 3: (the pop up in the middle bottom of screen)

memorysticky says: system settings>hardware>removable media>never prompt or start programs on media insertion I been trying to figure this out for a long ass time.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2011-11-29 05:35:42 -0600

Seen: 1,950 times

Last updated: Feb 21 '12