Ask Your Question
0

How to install the 32bit libraires needed for Secondlife viewer

asked 2017-02-11 09:33:17 -0500

Orriginal gravatar image

I am trying to run the "Secondlife Viewer" for linux. It is a 32 bit app on Fedora25 64bit, and when I try and run it from Terminal it comes back with an error saying --

64-bit Linux detected. Running from /home/me/SecondLife501323027i686 bin/do-not-directly-run-secondlife-bin: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory * Bad shutdown ($LLRUNERR). *

You are running the Second Life Viewer on a x86_64 platform. The most common problems when launching the Viewer (particularly 'bin/do-not-directly-run-secondlife-bin: not found' and 'error while loading shared libraries') may be solved by installing your Linux distribution's 32-bit compatibility packages. For example, on Ubuntu and other Debian-based Linuxes you might run: $ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl

I tried running a few suggestions from Earlier posts in this forum but still not working Any ideas please ? thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-02-13 02:09:30 -0500

fcomida gravatar image

updated 2017-02-14 13:31:10 -0500

I downloaded Second_Life_5_0_1_323027_i686.tar.bz2 just for testing, ran secondlife from the installation root....it works!!! By the way, you mentioned your system is Fedora 25 and you installed mesa-libGLU-9.0.0-10.fc24.i686 !?!?! Another thing, have you tried it in a X session? F25 uses wayland by default, it might be that if missing libGLU.so.1 has been fixed.

edit flag offensive delete link more

Comments

damn it, I didn't notice the f24 bit !!..

Orriginal gravatar imageOrriginal ( 2017-02-15 07:39:39 -0500 )edit
0

answered 2017-02-11 11:51:01 -0500

fcomida gravatar image

On my system sudo dnf provides \*/libGLU.so.1 gives: mesa-libGLU-9.0.0-10.fc24.x86_64 and mesa-libGLU-9.0.0-10.fc24.i686

edit flag offensive delete link more

Comments

I tried doing as you suggested but sadly I get the same error meesage as above..... I get this when I ran the comand mesa-libGLU-9.0.0-10.fc24.x86_64 : Mesa libGLU library Repo : @System

mesa-libGLU-9.0.0-10.fc24.i686 : Mesa libGLU library Repo : fedora

mesa-libGLU-9.0.0-10.fc24.x86_64 : Mesa libGLU library Repo : fedora

I then tried running it and it crashed out before the interface came up

Orriginal gravatar imageOrriginal ( 2017-02-12 03:31:11 -0500 )edit

Did you actually install mesa-libGLU.i686?

fcomida gravatar imagefcomida ( 2017-02-12 04:58:25 -0500 )edit

Yes- Installing : mesa-libGLU-9.0.0-10.fc24.i686 1/1 Verifying : mesa-libGLU-9.0.0-10.fc24.i686 1/1

Installed: mesa-libGLU.i686 9.0.0-10.fc24

Complete!

Orriginal gravatar imageOrriginal ( 2017-02-13 01:00:04 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-02-11 09:33:17 -0500

Seen: 667 times

Last updated: Feb 11 '17