Ask Your Question
0

Secondary Display not seen by Wayland: A way to force a signal to an output?

asked 2017-01-31 09:49:53 -0600

ppringle gravatar image

Hi,

I have a pesky display that uses HDMI. It is not recognized and auto-enabled, but if it's already on and receiving a signal, it will work. On Xorg, I could use xrandr to configure and send a signal to this output even if it wasn't recognized as connected and the display would work. I can't seem to find an equivalent for Wayland however since xrandr is read only.

What things I've tried to get the display to work already:

  • Reboot with only the HDMI connected and not my main display which uses VGA.
  • Keeping the display from going into power savings mode.

I believe this display is configured in such a way that Wayland/Xorg don't know it's there unless it knows they are there.

What I mean is, the HDMI doesn't work this way when using other devices like a Windows computer or a console/satellite receiver. I assume it's because those devices send the signal anyway and so the display wakes up and acknowledges it. Whereas, the two display servers expect to receive something first. It may have something to do with a weird EDID (the few times it has worked has shown it as a 28" display when it is 27"). But those are just guesses.

This monitor is a secondary display that I'd prefer to use as my primary. My hardware setup is as follows:

  • CPU with no iGPU
  • Dedicated GPU (AMD R7 240)
  • Primary 1600x900 display connected with VGA
  • Secondary 2560x1440 display connected with HDMI
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-02-05 10:20:16 -0600

Matt-1-2-3 gravatar image

I've got a possible work around for you. I have something very similar happen on my pc. What I do is after logging in to gnome, I go to settings and then displays. I then select the monitor that looks like its asleep and select rotate 90 degrees and hit appply then hit escape.

This will attempt to rotate the screen on your monitor and hitting escape will signify dont apply these settings. Works for me every time. Kind of a PITA but it works

edit flag offensive delete link more

Comments

I have a similar problem (with external monitors that would work fine normally, but if I suspend my laptop, on resume the laptop will detect the display but not wake the display up).

This trick works, but I'd love to figure out how to automate this without going through the Displays preferences -- or even better, to figure out what signal to send directly to wake this monitor up!

michel-slm gravatar imagemichel-slm ( 2018-07-23 12:19:19 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-01-31 09:49:53 -0600

Seen: 2,448 times

Last updated: Feb 05 '17