Increase timeout time for bluetooth keyboard

asked 2017-01-29 05:18:24 -0600

alfC gravatar image

I have this Microsoft Bluetooth Keyboard https://www.amazon.com/Microsoft-Blue...

It turns out that the bluetooth connection is erratic, usually what happens is that after a minute without using it, I press a key and if am lucky after 20 seconds I have it reconnected. If I am not lucky I have to go to the bluetooth panel of Fedora and reconnect it manually, sometimes I have to re-pair it.

I don't have much hopes that this problem will be resolved soon for this particular software. (If you have any tips I would like to know anyway). But, I am thinking that increasing the time out time for the bluetooth connection can make this problem appear less often.

Is there a way to increase the time out of bluetooth devices and of keyboards in particular?

or perhaps add an exeption to this device to allow automatic connection with no need for pairing.

This is the hardware information (line 5):

$ bluetoothctl 
[NEW] Controller 68:5D:43:50:E7:76 ChromeLinux_A06C [default]
[NEW] Device F4:F5:D8:B6:91:A7 F4-F5-D8-B6-91-A7
[NEW] Device 00:1A:7D:22:31:52 SB220
[NEW] Device 00:21:3C:8A:8E:24 JAMBOX by Jawbone
[NEW] Device 7C:1E:52:AB:1A:2F Microsoft Sculpt Mobile Keyboard    <--------------
[NEW] Device C0:EE:FB:E7:FE:B5 OnePlus 3T

[Microsoft Sculpt Mobile Keyboard]# info
Device 7C:1E:52:AB:1A:2F
    Name: Microsoft Sculpt Mobile Keyboard
    Alias: Microsoft Sculpt Mobile Keyboard
    Class: 0x002540
    Icon: input-keyboard
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: no
    UUID: Service Discovery Serve.. (00001000-0000-1000-8000-00805f9b34fb)
    UUID: Human Interface Device... (00001124-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v045Ep07A4d0102
[CHG] Device C0:EE:FB:E7:FE:B5 RSSI: -63
edit retag flag offensive close merge delete