Fedora 24 kernel version4.9.5-100 can't find wifi

asked 2017-01-24 09:34:27 -0600

CWu gravatar image

updated 2017-01-25 16:41:10 -0600

Just upgraded my kernel to 4.9.5-100 and now have lost wifi connectivity. (I am using a hard-wired connection.) dmesg reports

[ 1535.074197] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[ 1536.011730] wlp3s0: authenticate with b0:7f:b9:fe:86:45
[ 1540.435329] wlp3s0: send auth to b0:7f:b9:fe:86:45 (try 1/3)
[ 1541.851363] wlp3s0: send auth to b0:7f:b9:fe:86:45 (try 2/3)
[ 1542.843351] wlp3s0: send auth to b0:7f:b9:fe:86:45 (try 3/3)

and I get popup bubbles saying "The Wifi network could not be found." Had no issues with kernel 4.8.16-200. Is this a bug or am I missing something?

UPDATE: This issue seems to be a duplicate of https://ask.fedoraproject.org/en/ques... and is a known bug ( https://bugzilla.redhat.com/show_bug.... ). I suggest people follow the bug for updates.

edit retag flag offensive close merge delete

Comments

Well! Not sure if this the solution or not but my WiFi is now working with kernel 4.9.5-100 (FC24). I just tried, for the heck of it, completely shutting down the laptop then power up, rather than just restarting (without the power down). I will try it a few more times.

CWu gravatar imageCWu ( 2017-01-24 12:00:02 -0600 )edit

Same thing is happening to me, even on 4.9.4. I'm also using 4.8.16 until I find a fix. Please post here if you figure something out.

devil0150 gravatar imagedevil0150 ( 2017-01-24 12:43:18 -0600 )edit

I have had this happen as well with an Intel wireless chipset. In my case unloading the kernel module and reloading it worked to reset it.

ssieb gravatar imagessieb ( 2017-01-24 13:15:54 -0600 )edit

Unloading the module? Is that just running ifconfig wlo1 down?

devil0150 gravatar imagedevil0150 ( 2017-01-24 16:01:27 -0600 )edit

Report: Power cycling doesn't work. It's spotty at best. Samuel, how does one unload the kernel module?

CWu gravatar imageCWu ( 2017-01-24 19:17:51 -0600 )edit