Ask Your Question
1

Why does my Gnome screen flip vertically randomly?

asked 2017-01-13 05:28:43 -0600

powergame gravatar image

updated 2017-01-13 06:05:20 -0600

I am on Fedora 25 (x64). I don't know why my screen accidentally flips upside down for no clear reason. And then I have to run the following command with hardship to rotate it back to normal:
xrandr --output --rotate normal

Does anyone know why this happens and how I can prevent it altogether? It is worth mentioning that I also have other desktop environments installed (XFCE, KDE Plasma, Gnome on Wayland, but I had installed Fedora Workstation in the first place which has the default Gnome environment. Currently I am on Gnome on Xorg. Hope this helps.

More information:
Graphics Card: NVidia Quadro FX 880M (Gallium 0.4 on NVA5) RAM: 8 GB CPU: Core i7 Q 720 GNOME version: 3.22.2

edit retag flag offensive close merge delete

Comments

Oh @Period22 yes man! I had not noticed it. I locked it and I hope it will not come back.

powergame gravatar imagepowergame ( 2017-01-13 06:06:59 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-13 05:57:32 -0600

Period22 gravatar image

updated 2017-01-13 05:58:51 -0600

Do you have a laptop with rotation sensors? If yes, there should be a "Lock rotation" icon in the top right menu. See here for what it looks like.

edit flag offensive delete link more

Comments

According to this, you can also permanently disable Gnome screen orientation with this command:

gsettings set org.gnome.settings-daemon.plugins.orientation active false

Can't test it myself!

Period22 gravatar imagePeriod22 ( 2017-01-13 10:37:26 -0600 )edit

This key no longer seems to exist. I could only find a key to (dis)allow the orientation lock (/org/gnome/settings-daemon/peripherals/touchscreen/orientation-lock). #FML

steeve gravatar imagesteeve ( 2017-10-11 08:07:17 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-01-13 05:28:43 -0600

Seen: 2,189 times

Last updated: Jan 13 '17