Ask Your Question

Revision history [back]

I searched a bit but I was unable to find any package providing this exact library (libcblas.so.3) in F22.

I've found this ticket. Have a look there, you know better, to me it seems relevant to your problem.

Downgrading a package is not a solution, per my opinion, but in such situations is a good workaround until the problem resolved.

I've found similar library in gsl package but I'm not sure if will work for you. Try to install this package and see if it works.

sudo dnf install gsl gsl-devel

provide libgslcblas.so.0 and libgslcblas.so

You can try to manually "hack" and create a symlink which points to one of these libraries and see if it works,

example:

sudo ln -s /lib64/libgslcblas.so.0 /lib64/libcblas.so.3

or try to link your programs directly.