Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

These conflicts are between the i686 version of the packages with the x86_64 versions. One way this can happen is if you have duplicate packages installed (when, for example, dnf crashes during an update). You can check if you have dupes for these packages with:

rpm -q libcom_err libattr

You can run the following to remove duplicates

sudo dnf remove --duplicates

Also, you may no longer need the i686 versions of these packages, and you could just try and remove them to see what happens:

sudo dnf remove libcom_err.i686 sudo dnf remove libattr.i686

(Definitely don't want to pass in the -y in instances like this since these removes may want to remove a lot of important packages, in which case you'll want to cancel the remove ...)

You should fix this before trying to upgrade to Fedora 29.