Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Is dnf update sayting something like this

================================================================================================
 Package                       Arch                Version                    Repository            Size
================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                    x86_64              5.11.1-7.fc28              updates              3.3 M
Skipping packages with broken dependencies:
 python2-qt5                   x86_64              5.10.1-4.fc28              updates              1.2 M
 python2-qt5-base              x86_64              5.10.1-4.fc28              updates              2.7 M
 python3-qt5                   x86_64              5.10.1-4.fc28              updates              1.2 M

Transaction Summary
================================================================================================
Skip  4 Packages

Nothing to do.

?

That usually means that you have another package installed that is depending on the qt-5.10.x package. You have to wait for that package to be updated, or you remove it and thus removing the dependency on the older qt5 package(s).

FYI: I have something similar going on, in my case qgis needs qt5-qtbase-5.10.1-6.fc28.x86_64 (libQt5Core.so.5(Qt_5.10.1_PRIVATE_API). See here for details. Maybe your dnf update is telling you something simiar.

Is dnf update sayting something like this

================================================================================================
=====================================================================================
 Package                       Arch                Version                 Repository          Size
================================================================================================
=====================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                    x86_64              5.11.1-7.fc28           updates            3.3 M
Skipping packages with broken dependencies:
 python2-qt5                   x86_64              5.10.1-4.fc28           updates             1.2 M
 python2-qt5-base              x86_64              5.10.1-4.fc28           updates             2.7 M
 python3-qt5                   x86_64              5.10.1-4.fc28           updates             1.2 M

Transaction Summary
================================================================================================
=====================================================================================
Skip  4 Packages

Nothing to do.

?

That usually means that you have another package installed that is depending on the qt-5.10.x package. You have to wait for that package to be updated, or you remove it and thus removing the dependency on the older qt5 package(s).

FYI: I have something similar going on, in my case qgis needs qt5-qtbase-5.10.1-6.fc28.x86_64 (libQt5Core.so.5(Qt_5.10.1_PRIVATE_API). See here for details. Maybe your dnf update is telling you something simiar.

click to hide/show revision 3
No.3 Revision

Is dnf update sayting something like this

=====================================================================================
 Package                       Arch                Version                Repository         Size
=====================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                    x86_64              5.11.1-7.fc28          updates           3.3 M
Skipping packages with broken dependencies:
 python2-qt5                   x86_64              5.10.1-4.fc28          updates            1.2 M
 python2-qt5-base              x86_64              5.10.1-4.fc28          updates            2.7 M
 python3-qt5                   x86_64              5.10.1-4.fc28          updates            1.2 M

Transaction Summary
=====================================================================================
Skip  4 Packages

Nothing to do.

?

That usually means that you have another package installed that is depending on the qt-5.10.x package. You have to wait for that package to be updated, or you remove it and thus removing the dependency on the older qt5 package(s).

FYI: I have something similar going on, in my case qgis needs qt5-qtbase-5.10.1-6.fc28.x86_64 (libQt5Core.so.5(Qt_5.10.1_PRIVATE_API). (libQt5Core.so.5(Qt_5.10.1_PRIVATE_API). See here for details. Maybe your dnf update is telling you something simiar.