Ask Your Question

Revision history [back]

I have the same sort of problem with Fedora 27. When I install /boot/vmlinuz-4.13.9-300.fc27.x86_64 from Fedora Live I get a good installation and a good boot. But all subsequent dnf update operations which install a later version of the kernel fail to complete the boot process. Instead, I see that the boot process has encountered a kernel panic alert.

But Windows 10 installs on the same computer without a hitch! I ran memory diagnostics and disk diagnostics on my HP Elite 8000 SFF 8GB RAM to no avail. I exchanged the 160GB disk for a 2TB version and nothing changed. Win 10 continued to install trouble free, but Fedora 27 only boots with /boot/vmlinuz-4.13.9-300.fc27.x86_64 --- all later versions fail with a kernel panic alert.

I have another HP Elite 8000 SFF 8GB RAM which installs trouble free with every version of the kernel tried by me. Ditto for an HP Elite 8000 USF 4GB RAM. This is a tough nut to crack! One fact to note---all three of these computers were purchased as 'Refurbished' computers. I wonder if the problems might be related to some changes which might have been made to the BIOS. Hmmmm...