Ask Your Question

Revision history [back]

Sorry guys but it's all bullshit.

I've got same error on my Fedora-25-4.9.13-201.fc25.x86_64 $ sudo akmods --force --kernel uname -r --akmod wl Could not find files needed to compile modules for 4.9.13-201.fc25.x86_64 Are the development files for kernel 4.9.13-201.fc25.x86_64 or the appropriate kernel-devel package installed?

Problem solved by recomendations on http://linuxwireless.org/en/users/Drivers/b43/#Fedora

You need make all form this topic:

If you are using the b43 driver from 3.2 kernel or newer:

After installing b43-fwcutter, download version 5.100.138 of Broadcom's proprietary driver and extract the firmware from it:

Toggle line numbers    1 export FIRMWARE_INSTALL_DIR="/lib/firmware"    2 wget http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2    3 tar xjf broadcom-wl-5.100.138.tar.bz2    4 sudo b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" broadcom-wl-5.100.138/linux/wl_apsta.o 

Do exactly by listing above. And wifi appears when I comanded:

$ sudo modprobe b43

It's all. Peace!